ago 252013
 

Recentemente ho installato una VPS con Debian 7 su Linode e come prima cosa ho voluto fare un aggiornamento del sistema, ma ho trovato un piccolo problema in questo:

# apt-get update
0% [Connecting to ftp.us.debian.org (2610:148:1f10:3::89)] [Connecting to security.debian.org (2607:ea00:101:3c0b:207:e9ff:fe00:e595)]
Get:1 http://ftp.us.debian.org wheezy Release.gpg [1,672 B]                                                                           
...
Get:15 http://security.debian.org wheezy/updates/main Translation-en [56.6 kB]
Fetched 16.3 MB in <strong>4min 0s</strong> (67.5 kB/s)                                                                                                                                     
Reading package lists... Done

Quindi 4 minuti per aggiornare solo i miei repository (ed avevo solo il valore predefiniti per una Debian 7 appena installata), questo è dovuto al fatto che le VPS di Linode sono IPv6 Ready e quindi i server di questa azienda tentano di connettersi a security.debian. org tramite il suo indirizzo IPv6 di default quando si esegue un apt-get update, che si traduce in dover aspettare un lungo timeout ogni volta che si tenta di scaricare gli aggiornamenti di qualsiasi tipo.

Ma per fortuna cambiare il sistema operativo in modo che apt-get utilizzi IPv4 non è così difficile.
Continue reading »

flattr this!

nov 212012
 

Oggi avevo bisogno di installare 1 singolo pacchetto dalla versione unstable di Debian in un server installato con la versione stabile, quindi qual è il modo migliore per ottenere questo risultato?

Per questo esempio userò il pacchetto drush , perché ci sono un sacco di differenze tra le varie versioni di Debian.
Continue reading »

flattr this!

lug 222011
 

debian-tux Articolo originale di Monica Aguilar su usemoslinux.blogspot.com

Problemi di spazio? Forse la colpa non è del tutto dei vostri file musicali, immagini e video, ma i pacchetti di installazione e le dipendenze inutili nel sistema. Ma non disperate, ci sono alcuni comandi di apt-get che possono aiutare a risolvere questi problemi.

Apt

APT è Advanced Packing Tool, o Strumento avanzato di pacchettizzazione,  è responsabile della gestione dei pacchetti da installare e disinstallare, e le loro rispettive dipendenze. APT è stato creato per Debian, e progettato per lavorare con dpkg, ma ora alcune modifiche sono state fatte per funzionare con il gestore di pacchetti RPM con apt-rpm. Continue reading »

flattr this!